aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorEelco Dolstra <e.dolstra@tudelft.nl>2004-07-18 21:07:27 +0000
committerEelco Dolstra <e.dolstra@tudelft.nl>2004-07-18 21:07:27 +0000
commit39eaecbc982246a511810be578ef1ebbe9fd3c10 (patch)
tree6504865b2138be35a19e6d400f0b520583ec2f79 /configure.ac
parent064a36cb5454f32a45aac55f2a47532fc96dda25 (diff)
* Slightly better heuristic for picking the canonical system type.
Now SuSE and Red Hat should yield the same type (`i686-linux'). Mac OS X should now give `powerpc-darwin' (i.e., the version number is gone).
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac12
1 files changed, 7 insertions, 5 deletions
diff --git a/configure.ac b/configure.ac
index 851375194..9bc3a0288 100644
--- a/configure.ac
+++ b/configure.ac
@@ -22,12 +22,14 @@ AC_CANONICAL_HOST
# Construct a Nix system name (like "i686-linux").
AC_MSG_CHECKING([for the canonical Nix system name])
-#machine_name=`uname -m`
-#sys_name=`uname -s | tr [A-Z] [a-z]`
-#system="${machine_name}-${sys_name}"
+machine_name=$(uname -p | tr 'A-Z ' 'a-z_')
+if test "$machine_name" = "unknown"; then
+ machine_name=$(uname -m | tr 'A-Z ' 'a-z_')
+fi
+sys_name=$(uname -s | tr 'A-Z ' 'a-z_')
AC_ARG_WITH(system, AC_HELP_STRING([--with-system=SYSTEM],
[platform identifier (e.g., `i686-linux')]),
- system=$withval, system="$host_cpu-$host_os")
+ system=$withval, system="${machine_name}-${sys_name}")
AC_MSG_RESULT($system)
AC_SUBST(system)
AC_DEFINE_UNQUOTED(SYSTEM, ["$system"], [platform identifier (`cpu-os')])
@@ -56,7 +58,7 @@ AC_DEFUN([NEED_PROG],
[
AC_PATH_PROG($1, $2)
if test -z "$$1"; then
- AC_MSG_ERROR([$1 is required])
+ AC_MSG_ERROR([$2 is required])
fi
])