aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorEelco Dolstra <eelco.dolstra@logicblox.com>2012-05-10 19:03:23 -0400
committerEelco Dolstra <eelco.dolstra@logicblox.com>2012-05-10 19:03:23 -0400
commit4f7bab7db1d0447e41f858633cddba1dcb2c9ea2 (patch)
tree818adb7b019671906e2b9016b4c265ebc53cfdf1 /configure.ac
parent6a7b24a3f25548fe2b083555cd2117dd66557ab0 (diff)
Support building with the Perl XS bindings disabled
Since the Perl bindings require shared libraries, this is required on platforms such as Cygwin where we do a static build.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac25
1 files changed, 16 insertions, 9 deletions
diff --git a/configure.ac b/configure.ac
index 0f6b752f2..7b814dedc 100644
--- a/configure.ac
+++ b/configure.ac
@@ -71,7 +71,7 @@ fi
AC_PROG_CC
AC_PROG_CXX
-# To build programs to be run in the build machine
+# To build programs to be run in the build machine.
if test "$CC_FOR_BUILD" = ""; then
if test "$cross_compiling" = "yes"; then
AC_CHECK_PROGS(CC_FOR_BUILD, gcc cc)
@@ -86,13 +86,6 @@ AC_DISABLE_STATIC
AC_ENABLE_SHARED
AC_PROG_LIBTOOL
-if test "$enable_shared" = yes; then
- SUB_CONFIGURE_FLAGS="--enable-shared --disable-static"
-else
- SUB_CONFIGURE_FLAGS="--enable-static --disable-shared"
-fi
-AC_SUBST(SUB_CONFIGURE_FLAGS)
-
# Use 64-bit file system calls so that we can support files > 2 GiB.
AC_SYS_LARGEFILE
@@ -247,7 +240,7 @@ PKG_CHECK_MODULES([SQLITE3], [sqlite3 >= 3.6.19], [CXXFLAGS="$SQLITE3_CFLAGS $CX
# Whether to use the Boehm garbage collector.
AC_ARG_ENABLE(gc, AC_HELP_STRING([--enable-gc],
- [enable garbage collection in the Nix expression evaluator (requires Boehm GC)]),
+ [enable garbage collection in the Nix expression evaluator (requires Boehm GC) [default=no]]),
gc=$enableval, gc=no)
if test "$gc" = yes; then
PKG_CHECK_MODULES([BDW_GC], [bdw-gc])
@@ -277,6 +270,20 @@ AC_MSG_RESULT(yes)
AC_SUBST(perlFlags)
+# Whether to build the Perl bindings
+AC_MSG_CHECKING([whether to build the Perl bindings])
+AC_ARG_ENABLE(perl-bindings, AC_HELP_STRING([--enable-perl-bindings],
+ [whether to build the Perl bindings (recommended) [default=yes]]),
+ perlbindings=$enableval, perlbindings=yes)
+if test "$enable_shared" = no; then
+ # Perl bindings require shared libraries.
+ perlbindings=no
+fi
+AM_CONDITIONAL(PERL_BINDINGS, test "$perlbindings" = "yes")
+AC_SUBST(perlbindings)
+AC_MSG_RESULT($perlbindings)
+
+
AC_ARG_ENABLE(init-state, AC_HELP_STRING([--disable-init-state],
[do not initialise DB etc. in `make install']),
init_state=$enableval, init_state=yes)