aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorEelco Dolstra <e.dolstra@tudelft.nl>2012-01-04 12:45:40 +0000
committerEelco Dolstra <e.dolstra@tudelft.nl>2012-01-04 12:45:40 +0000
commit9d43a0238235cfbe914e2051db89095699a2df95 (patch)
tree8759279c2872d91f2ef0ef4888b92bc519cc061a /configure.ac
parenta0477a458fa9fd7fbe090ff8cebcfd162c090b43 (diff)
* Let --disable-gc work.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac4
1 files changed, 2 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index 52c92b76b..1e8665992 100644
--- a/configure.ac
+++ b/configure.ac
@@ -274,8 +274,8 @@ AC_SUBST(sqlite_bin)
# Whether to use the Boehm garbage collector.
AC_ARG_ENABLE(gc, AC_HELP_STRING([--enable-gc],
[enable garbage collection in the Nix expression evaluator (requires Boehm GC)]),
- gc=$enableval, gc=)
-if test -n "$gc"; then
+ gc=$enableval, gc=no)
+if test "$gc" = yes; then
PKG_CHECK_MODULES([BDW_GC], [bdw-gc])
CXXFLAGS="$BDW_GC_CFLAGS $CXXFLAGS"
AC_DEFINE(HAVE_BOEHMGC, 1, [Whether to use the Boehm garbage collector.])