aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorEelco Dolstra <e.dolstra@tudelft.nl>2011-02-09 12:41:54 +0000
committerEelco Dolstra <e.dolstra@tudelft.nl>2011-02-09 12:41:54 +0000
commitd0eda1f3e9b2030e373038fd8997f033f2d7aedd (patch)
tree9db733f87fceaba36ddcba54b794b8be06c1d136 /configure.ac
parent3854fc9b42d16b810f62b64194b699033b03aaf1 (diff)
parent543988572e2abc85767da315b2acc1f971c5d07f (diff)
* Merged the SQLite branch.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac69
1 files changed, 36 insertions, 33 deletions
diff --git a/configure.ac b/configure.ac
index f108c53be..e34e4ba3a 100644
--- a/configure.ac
+++ b/configure.ac
@@ -50,39 +50,24 @@ AC_DEFINE_UNQUOTED(SYSTEM, ["$system"], [platform identifier (`cpu-os')])
test "$localstatedir" = '${prefix}/var' && localstatedir=/nix/var
-# Whether to produce a statically linked binary. On Cygwin, this is
-# the default: dynamically linking against the ATerm DLL does work,
-# except that it requires the ATerm "lib" directory to be in $PATH, as
-# Windows doesn't have anything like an RPATH embedded in executable.
-# Since this is kind of annoying, we use static libraries for now.
-
-AC_ARG_ENABLE(static-nix, AC_HELP_STRING([--enable-static-nix],
- [produce statically linked binaries]),
- static_nix=$enableval, static_nix=no)
-
-if test "$sys_name" = cygwin; then
- static_nix=yes
-fi
-
-if test "$static_nix" = yes; then
+# Windows-specific stuff. On Cygwin, dynamically linking against the
+# ATerm DLL works, except that it requires the ATerm "lib" directory
+# to be in $PATH, as Windows doesn't have anything like an RPATH
+# embedded in executable. Since this is kind of annoying, we use
+# static libraries for now.
+if test "$sys_name" = "cygwin"; then
AC_DISABLE_SHARED
AC_ENABLE_STATIC
fi
-# Windows-specific stuff.
-if test "$sys_name" = "cygwin"; then
- # We cannot delete open files.
- AC_DEFINE(CANNOT_DELETE_OPEN_FILES, 1, [Whether it is impossible to delete open files.])
-fi
-
# Solaris-specific stuff.
if test "$sys_name" = "sunos"; then
# Solaris requires -lsocket -lnsl for network functions
- ADDITIONAL_NETWORK_LIBS="-lsocket -lnsl"
- AC_SUBST(ADDITIONAL_NETWORK_LIBS)
+ LIBS="-lsocket -lnsl $LIBS"
fi
+
AC_PROG_CC
AC_PROG_CXX
@@ -101,6 +86,13 @@ AC_DISABLE_STATIC
AC_ENABLE_SHARED
AC_PROG_LIBTOOL
+if test "$enable_shared" = yes; then
+ SUB_CONFIGURE_FLAGS="--enable-shared --disable-static"
+else
+ SUB_CONFIGURE_FLAGS="--enable-static --disable-shared"
+fi
+AC_SUBST(SUB_CONFIGURE_FLAGS)
+
# Use 64-bit file system calls so that we can support files > 2 GiB.
AC_SYS_LARGEFILE
@@ -229,6 +221,8 @@ AC_ARG_WITH(bzip2, AC_HELP_STRING([--with-bzip2=PATH],
[prefix of bzip2]),
bzip2=$withval, bzip2=)
AM_CONDITIONAL(HAVE_BZIP2, test -n "$bzip2")
+ATERM_VERSION=2.5
+AC_SUBST(ATERM_VERSION)
if test -z "$bzip2"; then
# Headers and libraries will be used from the temporary installation
# in externals/inst-bzip2.
@@ -249,6 +243,24 @@ AC_SUBST(bzip2_include)
AC_SUBST(bzip2_bin)
AC_SUBST(bzip2_bin_test)
+AC_ARG_WITH(sqlite, AC_HELP_STRING([--with-sqlite=PATH],
+ [prefix of SQLite]),
+ sqlite=$withval, sqlite=)
+AM_CONDITIONAL(HAVE_SQLITE, test -n "$sqlite")
+SQLITE_VERSION=3070500
+AC_SUBST(SQLITE_VERSION)
+if test -z "$sqlite"; then
+ sqlite_lib='${top_builddir}/externals/sqlite-autoconf-$(SQLITE_VERSION)/libsqlite3.la'
+ sqlite_include='-I${top_builddir}/externals/sqlite-autoconf-$(SQLITE_VERSION)'
+ sqlite_bin='${top_builddir}/externals/sqlite-autoconf-$(SQLITE_VERSION)'
+else
+ sqlite_lib="-L$sqlite/lib -lsqlite3"
+ sqlite_include="-I$sqlite/include"
+ sqlite_bin="$sqlite/bin"
+fi
+AC_SUBST(sqlite_lib)
+AC_SUBST(sqlite_include)
+AC_SUBST(sqlite_bin)
# Whether to use the Boehm garbage collector.
AC_ARG_ENABLE(gc, AC_HELP_STRING([--enable-gc],
@@ -274,8 +286,7 @@ AC_CHECK_FUNCS([setresuid setreuid lchown])
# Nice to have, but not essential.
-AC_CHECK_FUNCS([strsignal])
-AC_CHECK_FUNCS([posix_fallocate])
+AC_CHECK_FUNCS([strsignal posix_fallocate nanosleep])
# This is needed if ATerm or bzip2 are static libraries,
@@ -285,14 +296,6 @@ if test "$(uname)" = "Darwin"; then
fi
-if test "$static_nix" = yes; then
- # `-all-static' has to be added at the end of configure, because
- # the C compiler doesn't know about -all-static (it's filtered out
- # by libtool, but configure doesn't use libtool).
- LDFLAGS="-all-static $LDFLAGS"
-fi
-
-
AM_CONFIG_HEADER([config.h])
AC_CONFIG_FILES([Makefile
externals/Makefile