aboutsummaryrefslogtreecommitdiff
path: root/corepkgs/Makefile.am
diff options
context:
space:
mode:
authorEelco Dolstra <e.dolstra@tudelft.nl>2012-01-03 01:51:38 +0000
committerEelco Dolstra <e.dolstra@tudelft.nl>2012-01-03 01:51:38 +0000
commit39d45a6b090b5105423b22b8ef39c2a4a000a4a1 (patch)
tree945e102b1f482f8eb393fe1c597b8ea499b26bf3 /corepkgs/Makefile.am
parentdadbb51d969517c1f2512015ab201dc99088d9a6 (diff)
* Add a test for nix-channel.
* Refactor the nix-channel unpacker a bit.
Diffstat (limited to 'corepkgs/Makefile.am')
-rw-r--r--corepkgs/Makefile.am8
1 files changed, 4 insertions, 4 deletions
diff --git a/corepkgs/Makefile.am b/corepkgs/Makefile.am
index 7f43a700e..86d7027ed 100644
--- a/corepkgs/Makefile.am
+++ b/corepkgs/Makefile.am
@@ -1,11 +1,11 @@
-SUBDIRS = channels
-
all-local: config.nix
+files = nar.nix buildenv.nix buildenv.pl unpack-channel.nix unpack-channel.sh
+
install-exec-local:
$(INSTALL) -d $(DESTDIR)$(datadir)/nix/corepkgs
- $(INSTALL_DATA) config.nix $(srcdir)/nar.nix $(srcdir)/buildenv.nix $(srcdir)/buildenv.pl $(DESTDIR)$(datadir)/nix/corepkgs
+ $(INSTALL_DATA) config.nix $(files) $(DESTDIR)$(datadir)/nix/corepkgs
include ../substitute.mk
-EXTRA_DIST = config.nix.in nar.nix buildenv.nix buildenv.pl
+EXTRA_DIST = config.nix.in $(files)