aboutsummaryrefslogtreecommitdiff
path: root/corepkgs/config.nix.in
diff options
context:
space:
mode:
authorEelco Dolstra <edolstra@gmail.com>2019-03-27 23:40:35 +0100
committerEelco Dolstra <edolstra@gmail.com>2019-11-26 22:07:28 +0100
commit045708db4343174f30f3647776971c852f72a9e8 (patch)
treec37c82882d48e44338c9bae61eacb3839421f359 /corepkgs/config.nix.in
parente60f6bd4ce831ced94fafeb527c429b6f88159ac (diff)
Make <nix/unpack-channel.nix> a builtin builder
This was the last function using a shell script, so this allows us to get rid of tar, coreutils, bash etc.
Diffstat (limited to 'corepkgs/config.nix.in')
-rw-r--r--corepkgs/config.nix.in10
1 files changed, 1 insertions, 9 deletions
diff --git a/corepkgs/config.nix.in b/corepkgs/config.nix.in
index 32ce6b399..4ea182d8f 100644
--- a/corepkgs/config.nix.in
+++ b/corepkgs/config.nix.in
@@ -1,3 +1,4 @@
+# FIXME: remove this file?
let
fromEnv = var: def:
let val = builtins.getEnv var; in
@@ -17,13 +18,4 @@ in rec {
nixLocalstateDir = "@localstatedir@";
nixSysconfDir = "@sysconfdir@";
nixStoreDir = fromEnv "NIX_STORE_DIR" "@storedir@";
-
- # If Nix is installed in the Nix store, then automatically add it as
- # a dependency to the core packages. This ensures that they work
- # properly in a chroot.
- chrootDeps =
- if dirOf nixPrefix == builtins.storeDir then
- [ (builtins.storePath nixPrefix) ]
- else
- [ ];
}