aboutsummaryrefslogtreecommitdiff
path: root/corepkgs/fetchurl.nix
diff options
context:
space:
mode:
authorEelco Dolstra <eelco.dolstra@logicblox.com>2015-03-24 11:15:45 +0100
committerEelco Dolstra <eelco.dolstra@logicblox.com>2015-03-24 11:15:45 +0100
commit6f0c6e20e03bc82fcf0d2198cf81fa2cf25c2f6c (patch)
tree0037f8a7f72bb2c0fd5cb89e8c37c03d1c8c8ebf /corepkgs/fetchurl.nix
parentb005e63ccf387add426aa9941ab9f5770307fe33 (diff)
Don't rely on __noChroot for corepkgs
This doesn't work anymore if the "strict" chroot mode is enabled. Instead, add Nix's store path as a dependency. This ensures that its closure is present in the chroot.
Diffstat (limited to 'corepkgs/fetchurl.nix')
-rw-r--r--corepkgs/fetchurl.nix9
1 files changed, 4 insertions, 5 deletions
diff --git a/corepkgs/fetchurl.nix b/corepkgs/fetchurl.nix
index 4faedb140..1ce88593c 100644
--- a/corepkgs/fetchurl.nix
+++ b/corepkgs/fetchurl.nix
@@ -14,7 +14,7 @@ let
'' + (if executable then "${coreutils}/chmod +x $out" else ""));
in
-
+
derivation {
name = baseNameOf (toString url);
builder = shell;
@@ -26,15 +26,12 @@ derivation {
outputHash = if outputHash != "" then outputHash else
if sha256 != "" then sha256 else if sha1 != "" then sha1 else md5;
outputHashMode = if executable then "recursive" else "flat";
-
+
inherit system url;
# No need to double the amount of network traffic
preferLocalBuild = true;
- # Don't build in a chroot because Nix's dependencies may not be there.
- __noChroot = true;
-
impureEnvVars = [
# We borrow these environment variables from the caller to allow
# easy proxy configuration. This is impure, but a fixed-output
@@ -42,4 +39,6 @@ derivation {
# by definition pure.
"http_proxy" "https_proxy" "ftp_proxy" "all_proxy" "no_proxy"
];
+
+ inherit chrootDeps;
}