aboutsummaryrefslogtreecommitdiff
path: root/corepkgs/fetchurl.nix
diff options
context:
space:
mode:
authorShea Levy <shea@shealevy.com>2012-07-08 10:32:12 -0400
committerEelco Dolstra <eelco.dolstra@logicblox.com>2012-07-09 15:29:49 -0400
commita994eb92a4e0d8744b244cd421c855d76831bdc0 (patch)
tree3697e5298dd6e6b7334c41ee2a49cb9c9e604b9e /corepkgs/fetchurl.nix
parent9d94a28bed39d0e9bcb3532cdac1a254a44efa97 (diff)
corepkgs/fetchurl.sh: Use config.nix's curl
Diffstat (limited to 'corepkgs/fetchurl.nix')
-rw-r--r--corepkgs/fetchurl.nix4
1 files changed, 3 insertions, 1 deletions
diff --git a/corepkgs/fetchurl.nix b/corepkgs/fetchurl.nix
index c85c007ff..758212015 100644
--- a/corepkgs/fetchurl.nix
+++ b/corepkgs/fetchurl.nix
@@ -1,3 +1,5 @@
+with import <nix/config.nix>;
+
# Argh, this thing is duplicated (more-or-less) in Nixpkgs. Need to
# find a way to combine them.
@@ -19,5 +21,5 @@ derivation {
outputHash = if outputHash != "" then outputHash else
if sha256 != "" then sha256 else if sha1 != "" then sha1 else md5;
- inherit system url;
+ inherit system url curl;
}