aboutsummaryrefslogtreecommitdiff
path: root/corepkgs/fetchurl/default.nix
diff options
context:
space:
mode:
authorEelco Dolstra <e.dolstra@tudelft.nl>2004-04-21 14:54:05 +0000
committerEelco Dolstra <e.dolstra@tudelft.nl>2004-04-21 14:54:05 +0000
commit21655a70f5a6e80b477d8bf758aa24eb0fcbdbfe (patch)
tree6a322bfa5291ede4d00d5d07c4d2c5a3ae395dac /corepkgs/fetchurl/default.nix
parentf79e9c2d22345eeb0c721a8cf5375101d33dc4c9 (diff)
* Channels. These allow you to stay current with an evolving set of
Nix expressions. To subscribe to a channel (needs to be done only once): nix-channel --add \ http://catamaran.labs.cs.uu.nl/dist/nix/channels/nixpkgs-unstable This just adds the given URL to ~/.nix-channels (which can also be edited manually). To update from all channels: nix-channel --update This fetches the latest expressions and pulls cache manifests. The default Nix expression (~/.nix-defexpr) is made to point to the conjunction of the expressions downloaded from all channels. So to update all installed derivations in the current user environment: nix-channel --update nix-env --upgrade '*' If you are really courageous, you can put this in a cronjob or something. You can subscribe to multiple channels. It is not entirely clear what happens when there are name clashes between derivations from different channels. From nix-env/main.cc it appears that the one with the lowest (highest?) hash will be used, which is pretty meaningless.
Diffstat (limited to 'corepkgs/fetchurl/default.nix')
-rw-r--r--corepkgs/fetchurl/default.nix8
1 files changed, 4 insertions, 4 deletions
diff --git a/corepkgs/fetchurl/default.nix b/corepkgs/fetchurl/default.nix
index 663bba4a3..8957662ec 100644
--- a/corepkgs/fetchurl/default.nix
+++ b/corepkgs/fetchurl/default.nix
@@ -1,8 +1,8 @@
-{system, url, md5}: derivation {
+{system, url, md5}:
+
+derivation {
name = baseNameOf (toString url);
- system = system;
builder = ./builder.sh;
- url = url;
- md5 = md5;
id = md5;
+ inherit system url md5;
}