aboutsummaryrefslogtreecommitdiff
path: root/doc/manual/Makefile.am
diff options
context:
space:
mode:
authorEelco Dolstra <e.dolstra@tudelft.nl>2003-12-02 15:36:49 +0000
committerEelco Dolstra <e.dolstra@tudelft.nl>2003-12-02 15:36:49 +0000
commit16d971bce70a2b3aab1d3c60101e00f264159c07 (patch)
tree37df452b1f9a43faf187ec322da1332628522df1 /doc/manual/Makefile.am
parent0d3a1a8582a7b0120e35c507165db6d02ceea258 (diff)
* A nice stylesheet for the manual.
Diffstat (limited to 'doc/manual/Makefile.am')
-rw-r--r--doc/manual/Makefile.am7
1 files changed, 5 insertions, 2 deletions
diff --git a/doc/manual/Makefile.am b/doc/manual/Makefile.am
index 53a913ce6..34039ba36 100644
--- a/doc/manual/Makefile.am
+++ b/doc/manual/Makefile.am
@@ -3,12 +3,14 @@ ENV = SGML_CATALOG_FILES=$(docbookcatalog)
XMLLINT = $(ENV) $(xmllint) $(xmlflags) --catalogs
XSLTPROC = $(ENV) $(xsltproc) $(xmlflags) --catalogs \
--param section.autolabel 1 \
- --param section.label.includes.component.label 1
+ --param section.label.includes.component.label 1 \
+ --param html.stylesheet \'style.css\'
SOURCES = book.xml introduction.xml installation.xml \
overview.xml \
nix-store-reference.xml nix-instantiate-reference.xml \
- troubleshooting.xml bugs.xml
+ troubleshooting.xml bugs.xml \
+ style.css
book.is-valid: $(SOURCES)
$(XMLLINT) --noout --valid book.xml
@@ -27,6 +29,7 @@ all-local: book.html
install-data-local: book.html
$(INSTALL) -d $(datadir)/nix/manual
$(INSTALL_DATA) book.html $(datadir)/nix/manual
+ $(INSTALL_DATA) style.css $(datadir)/nix/manual
EXTRA_DIST = $(SOURCES) book.html book.is-valid $(MANS)