aboutsummaryrefslogtreecommitdiff
path: root/doc/manual/utils.nix
diff options
context:
space:
mode:
authorJohn Ericson <John.Ericson@Obsidian.Systems>2023-04-04 22:57:11 -0400
committerJohn Ericson <John.Ericson@Obsidian.Systems>2023-04-04 22:57:11 -0400
commit53d0836347ea262884658036f97bf19ecbdc5c26 (patch)
tree1e44ef6c424772ee311c34b4dcd772ac7a3ad96c /doc/manual/utils.nix
parent3f98353f196bfd1da3641751f4f7826f42581893 (diff)
Assemble experimental feature docs outside of Nix itself
Instead of constructing a markdown list in C++ (which involved all sorts of nasty string literals), export some JSON and assemble it with the manual build system. Besides following the precedent set with other dumped data, this is a better separate of content and presentation; if we decide for example we want to display this information in a different way, or in a different section of the manual, it will become much easier to do so.
Diffstat (limited to 'doc/manual/utils.nix')
-rw-r--r--doc/manual/utils.nix6
1 files changed, 3 insertions, 3 deletions
diff --git a/doc/manual/utils.nix b/doc/manual/utils.nix
index 5eacce0dd..f78e6bb02 100644
--- a/doc/manual/utils.nix
+++ b/doc/manual/utils.nix
@@ -74,10 +74,10 @@ rec {
if aliases == [] then "" else
"**Deprecated alias:** ${(concatStringsSep ", " (map (s: "`${s}`") aliases))}";
- indent = prefix: s:
- concatStringsSep "\n" (map (x: if x == "" then x else "${prefix}${x}") (splitLines s));
-
in result;
+ indent = prefix: s:
+ concatStringsSep "\n" (map (x: if x == "" then x else "${prefix}${x}") (splitLines s));
+
showSettings = args: settingsInfo: concatStrings (attrValues (mapAttrs (showSetting args) settingsInfo));
}