aboutsummaryrefslogtreecommitdiff
path: root/docker.nix
diff options
context:
space:
mode:
authorAlex Wied <centromere@users.noreply.github.com>2022-06-28 16:38:19 -0400
committerAlex Wied <centromere@users.noreply.github.com>2022-07-01 17:53:14 -0400
commit07416a6005fe035baa8646c6827904afb5226f95 (patch)
treee633cf6b8101d84a7e5a1210750969c278ebc6e5 /docker.nix
parentb7eb4ac1692e289912f3988c0e28bb2c778a4f7a (diff)
Allow specification of extra packages, maxLayers in Docker image
Diffstat (limited to 'docker.nix')
-rw-r--r--docker.nix6
1 files changed, 4 insertions, 2 deletions
diff --git a/docker.nix b/docker.nix
index 0cd64856f..ddf6feff5 100644
--- a/docker.nix
+++ b/docker.nix
@@ -4,6 +4,8 @@
, tag ? "latest"
, channelName ? "nixpkgs"
, channelURL ? "https://nixos.org/channels/nixpkgs-unstable"
+, extraPkgs ? []
+, maxLayers ? 100
}:
let
defaultPkgs = with pkgs; [
@@ -23,7 +25,7 @@ let
iana-etc
git
openssh
- ];
+ ] ++ extraPkgs;
users = {
@@ -229,7 +231,7 @@ let
in
pkgs.dockerTools.buildLayeredImageWithNixDb {
- inherit name tag;
+ inherit name tag maxLayers;
contents = [ baseSystem ];