diff options
author | Eelco Dolstra <edolstra@gmail.com> | 2019-05-02 21:10:13 +0200 |
---|---|---|
committer | Eelco Dolstra <edolstra@gmail.com> | 2019-05-02 21:10:13 +0200 |
commit | 2919c496ea10a99d08baffbef485cfb719233b9f (patch) | |
tree | ce114825d71789122a00e717ca0d1bee2754f7c9 /flake.nix | |
parent | 7dcf5b011a0942ecf953f2b607c4c8d0e9e652c7 (diff) |
nix dev-shell: Use 'provides.devShell' by default
Thus
$ nix dev-shell
will now build the 'provides.devShell' attribute from the flake in the
current directory. If it doesn't exist, it falls back to
'provides.defaultPackage'.
Diffstat (limited to 'flake.nix')
-rw-r--r-- | flake.nix | 5 |
1 files changed, 5 insertions, 0 deletions
@@ -17,5 +17,10 @@ packages.nix = hydraJobs.build.x86_64-linux; defaultPackage = packages.nix; + + devShell = import ./shell.nix { + nixpkgs = deps.nixpkgs; + }; + }; } |