aboutsummaryrefslogtreecommitdiff
path: root/flake.nix
diff options
context:
space:
mode:
authoreldritch horrors <pennae@lix.systems>2024-03-05 21:11:59 +0100
committereldritch horrors <pennae@lix.systems>2024-03-05 21:11:59 +0100
commit2e1f5e2666b6a0692e6c7c949563e41f16662119 (patch)
tree6b92920e0629761760a7ef51a905749e0ead872b /flake.nix
parent5bda6d9dc897bf60be4025cac418dcbdd835bf3c (diff)
Merge pull request #9105 from Ericson2314/split-out-nixos-tests
Define NixOS tests in `tests/nixos/default.nix` rather than `flake.nix` (cherry picked from commit c29b8ba142a0650d1182ca838ddc1b2d273dcd2a) Change-Id: Ieae1b6476d95024485df7067e008013bc5542039
Diffstat (limited to 'flake.nix')
-rw-r--r--flake.nix74
1 files changed, 21 insertions, 53 deletions
diff --git a/flake.nix b/flake.nix
index 827036646..a6182b02a 100644
--- a/flake.nix
+++ b/flake.nix
@@ -512,18 +512,6 @@
};
};
- nixos-lib = import (nixpkgs + "/nixos/lib") { };
-
- # https://nixos.org/manual/nixos/unstable/index.html#sec-calling-nixos-tests
- runNixOSTestFor = system: test: nixos-lib.runTest {
- imports = [ test ];
- hostPkgs = nixpkgsFor.${system}.native;
- defaults = {
- nixpkgs.pkgs = nixpkgsFor.${system}.native;
- };
- _module.args.nixpkgs = nixpkgs;
- };
-
in {
# A Nixpkgs overlay that overrides the 'nix' and
# 'nix.perl-bindings' packages.
@@ -632,49 +620,29 @@
};
# System tests.
- tests.authorization = runNixOSTestFor "x86_64-linux" ./tests/nixos/authorization.nix;
-
- tests.remoteBuilds = runNixOSTestFor "x86_64-linux" ./tests/nixos/remote-builds.nix;
-
- tests.nix-copy-closure = runNixOSTestFor "x86_64-linux" ./tests/nixos/nix-copy-closure.nix;
-
- tests.nix-copy = runNixOSTestFor "x86_64-linux" ./tests/nixos/nix-copy.nix;
-
- tests.nssPreload = runNixOSTestFor "x86_64-linux" ./tests/nixos/nss-preload.nix;
-
- tests.githubFlakes = runNixOSTestFor "x86_64-linux" ./tests/nixos/github-flakes.nix;
-
- tests.sourcehutFlakes = runNixOSTestFor "x86_64-linux" ./tests/nixos/sourcehut-flakes.nix;
-
- tests.tarballFlakes = runNixOSTestFor "x86_64-linux" ./tests/nixos/tarball-flakes.nix;
+ tests = import ./tests/nixos { inherit lib nixpkgs nixpkgsFor; } // {
- tests.containers = runNixOSTestFor "x86_64-linux" ./tests/nixos/containers/containers.nix;
-
- tests.setuid = lib.genAttrs
- ["i686-linux" "x86_64-linux"]
- (system: runNixOSTestFor system ./tests/nixos/setuid.nix);
-
-
- # Make sure that nix-env still produces the exact same result
- # on a particular version of Nixpkgs.
- tests.evalNixpkgs =
- with nixpkgsFor.x86_64-linux.native;
- runCommand "eval-nixos" { buildInputs = [ nix ]; }
- ''
- type -p nix-env
- # Note: we're filtering out nixos-install-tools because https://github.com/NixOS/nixpkgs/pull/153594#issuecomment-1020530593.
- time nix-env --store dummy:// -f ${nixpkgs-regression} -qaP --drv-path | sort | grep -v nixos-install-tools > packages
- [[ $(sha1sum < packages | cut -c1-40) = ff451c521e61e4fe72bdbe2d0ca5d1809affa733 ]]
- mkdir $out
- '';
+ # Make sure that nix-env still produces the exact same result
+ # on a particular version of Nixpkgs.
+ evalNixpkgs =
+ with nixpkgsFor.x86_64-linux.native;
+ runCommand "eval-nixos" { buildInputs = [ nix ]; }
+ ''
+ type -p nix-env
+ # Note: we're filtering out nixos-install-tools because https://github.com/NixOS/nixpkgs/pull/153594#issuecomment-1020530593.
+ time nix-env --store dummy:// -f ${nixpkgs-regression} -qaP --drv-path | sort | grep -v nixos-install-tools > packages
+ [[ $(sha1sum < packages | cut -c1-40) = ff451c521e61e4fe72bdbe2d0ca5d1809affa733 ]]
+ mkdir $out
+ '';
- tests.nixpkgsLibTests =
- forAllSystems (system:
- import (nixpkgs + "/lib/tests/release.nix")
- { pkgs = nixpkgsFor.${system}.native;
- nixVersions = [ self.packages.${system}.nix ];
- }
- );
+ nixpkgsLibTests =
+ forAllSystems (system:
+ import (nixpkgs + "/lib/tests/release.nix")
+ { pkgs = nixpkgsFor.${system}.native;
+ nixVersions = [ self.packages.${system}.nix ];
+ }
+ );
+ };
metrics.nixpkgs = import "${nixpkgs-regression}/pkgs/top-level/metrics.nix" {
pkgs = nixpkgsFor.x86_64-linux.native;