diff options
author | Matthew Bauer <mjbauer95@gmail.com> | 2021-06-28 15:08:17 -0500 |
---|---|---|
committer | Matthew Bauer <mjbauer95@gmail.com> | 2021-06-28 15:08:17 -0500 |
commit | 6c13a3f7354d02fb3a38604ed601b76c011e826f (patch) | |
tree | 60851fb43403a601cc5aa1e2401954a5b4492577 /flake.nix | |
parent | 580583e0b386df181a3c30519c821275362b10e0 (diff) |
Support binaryTarballCross in gha
Diffstat (limited to 'flake.nix')
-rw-r--r-- | flake.nix | 7 |
1 files changed, 5 insertions, 2 deletions
@@ -387,7 +387,7 @@ # Binary tarball for various platforms, containing a Nix store # with the closure of 'nix' package, and the second half of # the installation script. - binaryTarball = nixpkgs.lib.genAttrs systems (system: binaryTarball nixpkgsFor.${system}); + binaryTarball = nixpkgs.lib.genAttrs systems (system: binaryTarball nixpkgsFor.${system} nixpkgsFor.${system}.nix nixpkgsFor.${system}); binaryTarballCross = nixpkgs.lib.genAttrs systems (system: builtins.listToAttrs (map (crossSystem: { name = crossSystem; @@ -498,7 +498,10 @@ # `NIX_DAEMON_SOCKET_PATH` which is required for the tests to work # againstLatestStable = testNixVersions pkgs pkgs.nix pkgs.nixStable; } "touch $out"; - }); + } // (if system == "x86_64-linux" then (builtins.listToAttrs (map (crossSystem: { + name = "binaryTarball-${crossSystem}"; + value = self.hydraJobs.binaryTarballCross.${system}.${crossSystem}; + }) crossSystems)) else {})); packages = forAllSystems (system: { inherit (nixpkgsFor.${system}) nix; |