aboutsummaryrefslogtreecommitdiff
path: root/flake.nix
diff options
context:
space:
mode:
authoreldritch horrors <pennae@lix.systems>2024-03-09 07:47:10 +0100
committereldritch horrors <pennae@lix.systems>2024-03-09 00:03:50 -0700
commit896e525681bbf696c330af4e51c5e161d3818350 (patch)
tree0605e7081feb0635c526e20fb29739d64cdfd88a /flake.nix
parent7e1f8b09a4968447ec039f2369919fcb2bd430b7 (diff)
Disable bear on all the things with darwin as hostPlatform
Just `stdenv.isDarwin` isn't enough because it doesn't apply to the build platform, which mean that cross packages building from darwin to another platform will have `isDarwin` set to false. Replace it by `stdenv.buildPlatform.isDarwin`. (cherry picked from commit a0cb75d96f76a3be48b9319e26d8ad78ef4e4525) (h/t jade for finding this one) Change-Id: If3cb74e6feaa5d51de550d9a140c71683c2214cd
Diffstat (limited to 'flake.nix')
-rw-r--r--flake.nix2
1 files changed, 1 insertions, 1 deletions
diff --git a/flake.nix b/flake.nix
index 76e8ecf9a..d9e16881f 100644
--- a/flake.nix
+++ b/flake.nix
@@ -638,7 +638,7 @@
outputs = [ "out" "dev" "doc" ];
nativeBuildInputs = nativeBuildDeps
- ++ lib.optional stdenv.cc.isClang pkgs.buildPackages.bear
+ ++ lib.optional (stdenv.cc.isClang && !stdenv.buildPlatform.isDarwin) pkgs.buildPackages.bear
++ lib.optional
(stdenv.cc.isClang && stdenv.hostPlatform == stdenv.buildPlatform)
pkgs.buildPackages.clang-tools