diff options
author | jade <lix@jade.fyi> | 2024-06-11 04:45:12 +0000 |
---|---|---|
committer | Gerrit Code Review <gerrit@localhost> | 2024-06-11 04:45:12 +0000 |
commit | 8a3d063a494c4b8c767190a5ce3e4075a75f9d07 (patch) | |
tree | 31ed3c6cdb149c56951658de2680a48fecfc57b0 /flake.nix | |
parent | f432e464dd1a11ef47b1487f1913cd9b5256c189 (diff) | |
parent | 82dc712d9312f06e653213d030b6db21529a422f (diff) |
Merge changes from topic "releng" into main
* changes:
releng: add prod environment, ready for release
releng: automatically figure out if we should tag latest for docker
releng: support multiarch docker images
manual: rewrite the docker guide now that we have images
Rewrite docker to be sensible and smaller
Implement docker upload in the releng tools
Diffstat (limited to 'flake.nix')
-rw-r--r-- | flake.nix | 23 |
1 files changed, 11 insertions, 12 deletions
@@ -8,6 +8,10 @@ url = "github:cachix/git-hooks.nix"; flake = false; }; + nix2container = { + url = "github:nlewo/nix2container"; + flake = false; + }; flake-compat = { url = "github:edolstra/flake-compat"; flake = false; @@ -20,6 +24,7 @@ nixpkgs, nixpkgs-regression, pre-commit-hooks, + nix2container, flake-compat, }: @@ -330,19 +335,13 @@ dockerImage = let pkgs = nixpkgsFor.${system}.native; - image = import ./docker.nix { - inherit pkgs; - tag = pkgs.nix.version; - }; + nix2container' = import nix2container { inherit pkgs system; }; in - pkgs.runCommand "docker-image-tarball-${pkgs.nix.version}" - { meta.description = "Docker image with Lix for ${system}"; } - '' - mkdir -p $out/nix-support - image=$out/image.tar.gz - ln -s ${image} $image - echo "file binary-dist $image" >> $out/nix-support/hydra-build-products - ''; + import ./docker.nix { + inherit pkgs; + nix2container = nix2container'.nix2container; + tag = pkgs.nix.version; + }; } // builtins.listToAttrs ( map (crossSystem: { |