diff options
author | Eelco Dolstra <edolstra@gmail.com> | 2020-09-01 10:31:17 +0200 |
---|---|---|
committer | GitHub <noreply@github.com> | 2020-09-01 10:31:17 +0200 |
commit | b721877b85bbf9f78fd2221d8eb540373ee1e889 (patch) | |
tree | 4c0d54f611c48dfbd38aecacb7ad4a124d96e4fc /flake.nix | |
parent | ebb8e076eb41e712be2eff51fbde971ddddda1ee (diff) | |
parent | 50f46836f3b1f8d45a3939611637041b24b656c3 (diff) |
Merge pull request #3857 from edolstra/markdown
Convert manual to Markdown
Diffstat (limited to 'flake.nix')
-rw-r--r-- | flake.nix | 38 |
1 files changed, 30 insertions, 8 deletions
@@ -2,8 +2,9 @@ description = "The purely functional package manager"; inputs.nixpkgs.url = "nixpkgs/nixos-20.03-small"; + inputs.lowdown-src = { url = "github:edolstra/lowdown/no-structs-in-anonymous-unions"; flake = false; }; - outputs = { self, nixpkgs }: + outputs = { self, nixpkgs, lowdown-src }: let @@ -62,10 +63,8 @@ buildDeps = [ bison flex - libxml2 - libxslt - docbook5 - docbook_xsl_ns + mdbook + lowdown autoconf-archive autoreconfHook @@ -74,9 +73,6 @@ openssl pkgconfig sqlite libarchive boost - (if lib.versionAtLeast lib.version "20.03pre" - then nlohmann_json - else nlohmann_json.override { multipleHeaders = true; }) nlohmann_json # Tests @@ -172,6 +168,7 @@ pkgconfig pkgs.perl boost + nlohmann_json ] ++ lib.optional (stdenv.isLinux || stdenv.isDarwin) libsodium; @@ -187,6 +184,30 @@ }; + lowdown = with final; stdenv.mkDerivation { + name = "lowdown-0.7.1"; + + /* + src = fetchurl { + url = https://kristaps.bsd.lv/lowdown/snapshots/lowdown-0.7.1.tar.gz; + hash = "sha512-1daoAQfYD0LdhK6aFhrSQvadjc5GsSPBZw0fJDb+BEHYMBLjqiUl2A7H8N+l0W4YfGKqbsPYSrCy4vct+7U6FQ=="; + }; + */ + + src = lowdown-src; + + outputs = [ "out" "dev" ]; + + buildInputs = [ which ]; + + configurePhase = + '' + ./configure \ + PREFIX=${placeholder "dev"} \ + BINDIR=${placeholder "out"}/bin + ''; + }; + }; hydraJobs = { @@ -435,6 +456,7 @@ '' PATH=$prefix/bin:$PATH unset PYTHONPATH + export MANPATH=$out/share/man:$MANPATH ''; }); |