aboutsummaryrefslogtreecommitdiff
path: root/flake.nix
diff options
context:
space:
mode:
authorEelco Dolstra <edolstra@gmail.com>2021-10-15 12:36:29 +0200
committerEelco Dolstra <edolstra@gmail.com>2021-10-15 12:36:29 +0200
commitbe35569a6e488563f00caee521eba451d9b63680 (patch)
tree100d8920560c2aaea53210a8eab90590d9ad9e36 /flake.nix
parent304180d0ded6bf166b051f2b2ce5c33c18c2bbfe (diff)
Run installTests on Hydra
Diffstat (limited to 'flake.nix')
-rw-r--r--flake.nix16
1 files changed, 9 insertions, 7 deletions
diff --git a/flake.nix b/flake.nix
index 2d0c44889..cad6b22f8 100644
--- a/flake.nix
+++ b/flake.nix
@@ -488,12 +488,7 @@
'';
*/
- };
-
- checks = forAllSystems (system: {
- binaryTarball = self.hydraJobs.binaryTarball.${system};
- perlBindings = self.hydraJobs.perlBindings.${system};
- installTests =
+ installTests = forAllSystems (system:
let pkgs = nixpkgsFor.${system}; in
pkgs.runCommand "install-tests" {
againstSelf = testNixVersions pkgs pkgs.nix pkgs.pkgs.nix;
@@ -505,7 +500,14 @@
# Disabled because the latest stable version doesn't handle
# `NIX_DAEMON_SOCKET_PATH` which is required for the tests to work
# againstLatestStable = testNixVersions pkgs pkgs.nix pkgs.nixStable;
- } "touch $out";
+ } "touch $out");
+
+ };
+
+ checks = forAllSystems (system: {
+ binaryTarball = self.hydraJobs.binaryTarball.${system};
+ perlBindings = self.hydraJobs.perlBindings.${system};
+ installTests = self.hydraJobs.installTests.${system};
});
packages = forAllSystems (system: {