aboutsummaryrefslogtreecommitdiff
path: root/flake.nix
diff options
context:
space:
mode:
authoreldritch horrors <pennae@lix.systems>2024-03-04 03:52:05 +0100
committereldritch horrors <pennae@lix.systems>2024-03-04 04:36:33 +0100
commitc36ba796dd53ee21e54fe1b0af756850e6d201af (patch)
treeeac2511008cf13a986567d1c00b7448364dfaccb /flake.nix
parent7e966819b59d968366a9df50bfaa7c7abd36d61e (diff)
Merge pull request #9096 from NixOS/dont-rebuild-twice-on-ci
Don't run the tests that require building if we're not building (cherry picked from commit 8cfa582f436db8066eff74cb084990367e014ce6) Change-Id: I6085ca6107349669407340d7a5e52639a2febc90
Diffstat (limited to 'flake.nix')
-rw-r--r--flake.nix7
1 files changed, 6 insertions, 1 deletions
diff --git a/flake.nix b/flake.nix
index ac1d0606a..1d03f1a1f 100644
--- a/flake.nix
+++ b/flake.nix
@@ -253,6 +253,7 @@
testNixVersions = pkgs: client: daemon: with commonDeps { inherit pkgs; }; with pkgs.lib; pkgs.stdenv.mkDerivation {
NIX_DAEMON_PACKAGE = daemon;
NIX_CLIENT_PACKAGE = client;
+ HAVE_LOCAL_NIX_BUILD = false;
name =
"nix-tests"
+ optionalString
@@ -272,9 +273,13 @@
enableParallelBuilding = true;
configureFlags = testConfigureFlags; # otherwise configure fails
- dontBuild = true;
doInstallCheck = true;
+ buildPhase = ''
+ # Remove the source files to make sure that we're not accidentally rebuilding Nix
+ rm src/**/*.cc
+ '';
+
installPhase = ''
mkdir -p $out
'';