diff options
author | eldritch horrors <pennae@lix.systems> | 2024-03-06 00:38:02 +0100 |
---|---|---|
committer | eldritch horrors <pennae@lix.systems> | 2024-03-05 23:36:11 -0700 |
commit | c67b392385cbaadb50acd2794a7e581368b5b39c (patch) | |
tree | 9ee99dba483b8c804331330e32541fcc29d3ccb8 /flake.nix | |
parent | bfe2facede727927a91bf19036430844df2f18b9 (diff) |
Merge pull request #9608 from NixOS/default-lowdown
Remove custom lowdown
(cherry picked from commit 790cf13c268c7197c276cc02efda4cfe64a3a688)
Change-Id: Ie01f9a69e81e793fc7ac869de943da370dc75e36
Diffstat (limited to 'flake.nix')
-rw-r--r-- | flake.nix | 27 |
1 files changed, 3 insertions, 24 deletions
@@ -3,10 +3,9 @@ inputs.nixpkgs.url = "github:NixOS/nixpkgs/nixos-23.05-small"; inputs.nixpkgs-regression.url = "github:NixOS/nixpkgs/215d4d0fd80ca5163643b03a33fde804a29cc1e2"; - inputs.lowdown-src = { url = "github:kristapsdz/lowdown"; flake = false; }; inputs.flake-compat = { url = "github:edolstra/flake-compat"; flake = false; }; - outputs = { self, nixpkgs, nixpkgs-regression, lowdown-src, flake-compat }: + outputs = { self, nixpkgs, nixpkgs-regression, flake-compat }: let inherit (nixpkgs) lib; @@ -178,7 +177,7 @@ [ buildPackages.bison buildPackages.flex - (lib.getBin buildPackages.lowdown-nix) + (lib.getBin buildPackages.lowdown) buildPackages.mdbook buildPackages.mdbook-linkcheck buildPackages.autoconf-archive @@ -201,7 +200,7 @@ openssl sqlite libarchive boost - lowdown-nix + lowdown libsodium ] ++ lib.optionals stdenv.isLinux [libseccomp] @@ -395,9 +394,6 @@ { nixStable = prev.nix; - # Forward from the previous stage as we don’t want it to pick the lowdown override - nixUnstable = prev.nixUnstable; - nix = with final; with commonDeps { @@ -493,23 +489,6 @@ meta.platforms = lib.platforms.unix; }); - - lowdown-nix = with final; currentStdenv.mkDerivation rec { - name = "lowdown-0.9.0"; - - src = lowdown-src; - - outputs = [ "out" "bin" "dev" ]; - - nativeBuildInputs = [ buildPackages.which ]; - - configurePhase = '' - ${if (currentStdenv.isDarwin && currentStdenv.isAarch64) then "echo \"HAVE_SANDBOX_INIT=false\" > configure.local" else ""} - ./configure \ - PREFIX=${placeholder "dev"} \ - BINDIR=${placeholder "bin"}/bin - ''; - }; }; in { |