diff options
author | Jade Lovelace <lix@jade.fyi> | 2024-06-13 15:11:28 -0700 |
---|---|---|
committer | Jade Lovelace <lix@jade.fyi> | 2024-06-13 15:14:22 -0700 |
commit | 068576042b3b58f8180b24a36c07199a1a3fd380 (patch) | |
tree | 85280fc1405549c6f00ac432125525fd124043cd /flake.nix | |
parent | d194939ff55e352f069f15c15f63dbcf8b96138c (diff) |
packaging: Move binaryTarball to a passthru attr in package.nix
This is motivated by flakes being bad and all the stuff that calls
things by "system" being utterly unable to cope with cross compilation.
So if we go shove it in package.nix it is suddenly usable from cross
contexts.
Usage:
```
nix build -L .#nix-riscv64-linux.binaryTarball
```
Change-Id: I702ebf2ac5bd9d1c57662f968b000073134df336
Diffstat (limited to 'flake.nix')
-rw-r--r-- | flake.nix | 8 |
1 files changed, 2 insertions, 6 deletions
@@ -152,8 +152,6 @@ } ); - binaryTarball = nix: pkgs: pkgs.callPackage ./nix-support/binary-tarball.nix { inherit nix; }; - overlayFor = getStdenv: final: prev: let @@ -236,13 +234,11 @@ ); # Perl bindings for various platforms. - perlBindings = forAllSystems (system: nixpkgsFor.${system}.native.nix.perl-bindings); + perlBindings = forAllSystems (system: nixpkgsFor.${system}.native.nix.passthru.perl-bindings); # Binary tarball for various platforms, containing a Nix store # with the closure of 'nix' package. - binaryTarball = forAllSystems ( - system: binaryTarball nixpkgsFor.${system}.native.nix nixpkgsFor.${system}.native - ); + binaryTarball = forAllSystems (system: nixpkgsFor.${system}.native.nix.passthru.binaryTarball); # docker image with Lix inside dockerImage = lib.genAttrs linux64BitSystems (system: self.packages.${system}.dockerImage); |