diff options
author | Théophane Hufschmitt <theophane.hufschmitt@tweag.io> | 2022-12-13 10:44:07 +0100 |
---|---|---|
committer | Théophane Hufschmitt <theophane.hufschmitt@tweag.io> | 2022-12-13 10:44:07 +0100 |
commit | 2ec6685eb038b295d488ded6e46cc56378e7d646 (patch) | |
tree | e1b36c4f3ff8df99384730511967a55b92cd6616 /flake.nix | |
parent | 6e31d27cba459a0aca697d118b5423ec48ad3969 (diff) |
Build Nix with the GC disabled in hydra
Make sure that it still compiles as it's easy to accidentally break one
of the `#if` guarded clauses
Diffstat (limited to 'flake.nix')
-rw-r--r-- | flake.nix | 2 |
1 files changed, 2 insertions, 0 deletions
@@ -420,6 +420,8 @@ buildCross = nixpkgs.lib.genAttrs crossSystems (crossSystem: nixpkgs.lib.genAttrs ["x86_64-linux"] (system: self.packages.${system}."nix-${crossSystem}")); + buildNoGc = nixpkgs.lib.genAttrs systems (system: self.packages.${system}.nix.overrideAttrs (a: { configureFlags = (a.configureFlags or []) ++ ["--enable-gc=no"];})); + # Perl bindings for various platforms. perlBindings = nixpkgs.lib.genAttrs systems (system: self.packages.${system}.nix.perl-bindings); |