aboutsummaryrefslogtreecommitdiff
path: root/flake.nix
diff options
context:
space:
mode:
authorjade <lix@jade.fyi>2024-06-26 22:11:52 +0000
committerGerrit Code Review <gerrit@localhost>2024-06-26 22:11:52 +0000
commit5dc85e8b72d1ba433f69200537146275ff1c4a03 (patch)
tree00822407548ca164a881590aadc136dfbca9269e /flake.nix
parent77c53645965ff733763073a81997371b4ec5d666 (diff)
parentf7d54cb6b106fc24673f62c9dce050615d71eb1d (diff)
Merge "packaging: make pegtl use the __forDefaults mechanism" into main
Diffstat (limited to 'flake.nix')
-rw-r--r--flake.nix9
1 files changed, 6 insertions, 3 deletions
diff --git a/flake.nix b/flake.nix
index 076d7e6f5..d2eefca76 100644
--- a/flake.nix
+++ b/flake.nix
@@ -197,16 +197,19 @@
busybox-sandbox-shell = final.busybox-sandbox-shell or final.default-busybox-sandbox-shell;
};
- pegtl = final.callPackage ./misc/pegtl.nix { };
+ pegtl = final.nix.passthru.pegtl;
# Export the patched version of boehmgc that Lix uses into the overlay
# for consumers of this flake.
- boehmgc-nix = final.nix.boehmgc-nix;
+ boehmgc-nix = final.nix.passthru.boehmgc-nix;
# And same thing for our build-release-notes package.
- build-release-notes = final.nix.build-release-notes;
+ build-release-notes = final.nix.passthru.build-release-notes;
};
in
{
+ # for repl debugging
+ inherit self;
+
# A Nixpkgs overlay that overrides the 'nix' and
# 'nix.perl-bindings' packages.
overlays.default = overlayFor (p: p.stdenv);