diff options
author | Jade Lovelace <lix@jade.fyi> | 2024-07-23 23:25:18 +0200 |
---|---|---|
committer | Jade Lovelace <lix@jade.fyi> | 2024-07-31 14:13:39 -0700 |
commit | 5eecdd3ae9f47b1aaac22134eced318ff3e4bc41 (patch) | |
tree | ac0540064fd14e50dd4c98058859326b47755364 /flake.nix | |
parent | b5c6ce7a537d91ee22d6876ba0166259da2ac3c0 (diff) |
releng: move officialRelease to version.json
This was causing a few bits of suffering downstream, in particular, in
the NixOS module, which, after this change, can have the
`officialRelease` stuff in *it* completely deleted since we now have
correct defaulting in package.nix for it.
It also eliminates some automated editing of Nix files, which is
certainly always welcome to eliminate.
Fixes: https://git.lix.systems/lix-project/lix/issues/406
Change-Id: Id12f3018cff4633e379dbfcbe26b7bc84922bdaf
Diffstat (limited to 'flake.nix')
-rw-r--r-- | flake.nix | 5 |
1 files changed, 3 insertions, 2 deletions
@@ -59,7 +59,8 @@ (Run `touch .nocontribmsg` to hide this message.) ''; - officialRelease = false; + versionJson = builtins.fromJSON (builtins.readFile ./version.json); + officialRelease = versionJson.official_release; # Set to true to build the release notes for the next release. buildUnreleasedNotes = true; @@ -419,7 +420,7 @@ pkgs: stdenv: let nix = pkgs.callPackage ./package.nix { - inherit stdenv officialRelease versionSuffix; + inherit stdenv versionSuffix; busybox-sandbox-shell = pkgs.busybox-sandbox-shell or pkgs.default-busybox-sandbox; internalApiDocs = false; }; |