aboutsummaryrefslogtreecommitdiff
path: root/flake.nix
diff options
context:
space:
mode:
authorJade Lovelace <lix@jade.fyi>2024-06-11 12:42:51 -0700
committerJade Lovelace <lix@jade.fyi>2024-06-12 15:34:23 -0700
commit6939ffc9f9b23878d5960dabd92a7884feec689b (patch)
tree460a1de4ec645d771bb129c1e5800ba9a9014885 /flake.nix
parent479055aee8a7e57669cbad608866014fab9fc05d (diff)
Check devShells in CI
We should not let these regress in CI by having broken dependencies or similar. Still need to fix the evaluation error checking in buildbot-nix, but this is a useful step regardless. Fixes: https://git.lix.systems/lix-project/lix/issues/383 Change-Id: I3883184165440e66256c989117f2ab2e54c3aafd
Diffstat (limited to 'flake.nix')
-rw-r--r--flake.nix8
1 files changed, 8 insertions, 0 deletions
diff --git a/flake.nix b/flake.nix
index a02ba06d6..16b92d022 100644
--- a/flake.nix
+++ b/flake.nix
@@ -212,6 +212,11 @@
# Binary package for various platforms.
build = forAllSystems (system: self.packages.${system}.nix);
+ devShell = forAllSystems (system: {
+ default = self.devShells.${system}.default;
+ clang = self.devShells.${system}.native-clangStdenvPackages;
+ });
+
rl-next = forAllSystems (
system:
let
@@ -319,6 +324,9 @@
checks = forAvailableSystems (
system:
{
+ # devShells and packages already get checked by nix flake check, so
+ # this is just jobs that are special
+
binaryTarball = self.hydraJobs.binaryTarball.${system};
perlBindings = self.hydraJobs.perlBindings.${system};
nixpkgsLibTests = self.hydraJobs.tests.nixpkgsLibTests.${system};