aboutsummaryrefslogtreecommitdiff
path: root/flake.nix
diff options
context:
space:
mode:
authorJohn Ericson <John.Ericson@Obsidian.Systems>2023-01-19 08:51:00 -0500
committerJohn Ericson <John.Ericson@Obsidian.Systems>2023-01-23 07:05:50 -0500
commit7fe308c2f840325199f49526b257bbe4ded5a909 (patch)
tree5ea58d3ca8724e4d464270a4a46093107cc5a9ab /flake.nix
parent90e630a542c163e4d0fa2fb28bc6e1782e4bd394 (diff)
Add `rapidcheck` dependency for testing
Property tests are great! Co-authored-by: Cole Helbling <cole.e.helbling@outlook.com>
Diffstat (limited to 'flake.nix')
-rw-r--r--flake.nix5
1 files changed, 4 insertions, 1 deletions
diff --git a/flake.nix b/flake.nix
index 573373c42..5796c54ea 100644
--- a/flake.nix
+++ b/flake.nix
@@ -82,7 +82,9 @@
});
configureFlags =
- lib.optionals stdenv.isLinux [
+ [
+ "CXXFLAGS=-I${lib.getDev rapidcheck}/extras/gtest/include"
+ ] ++ lib.optionals stdenv.isLinux [
"--with-boost=${boost}/lib"
"--with-sandbox-shell=${sh}/bin/busybox"
]
@@ -116,6 +118,7 @@
boost
lowdown-nix
gtest
+ rapidcheck
]
++ lib.optionals stdenv.isLinux [libseccomp]
++ lib.optional (stdenv.isLinux || stdenv.isDarwin) libsodium