diff options
author | Jade Lovelace <lix@jade.fyi> | 2024-06-06 11:35:03 -0700 |
---|---|---|
committer | Jade Lovelace <lix@jade.fyi> | 2024-06-06 15:08:12 -0700 |
commit | 9c77c62e731e3fb9b1a87414c5b2d7a52932a507 (patch) | |
tree | 3e2ec9a7ff5156be6828006a4890b641b4729bd9 /flake.nix | |
parent | 24057dcb6a5d33806de66de1e42137eca398350e (diff) |
Move version to a JSON file so we can have release names
Change-Id: I5ff3396a302565ee5ee6c2db97e048e403779076
Diffstat (limited to 'flake.nix')
-rw-r--r-- | flake.nix | 8 |
1 files changed, 3 insertions, 5 deletions
@@ -59,7 +59,6 @@ # Set to true to build the release notes for the next release. buildUnreleasedNotes = true; - version = lib.fileContents ./.version + versionSuffix; versionSuffix = if officialRelease then "" @@ -149,8 +148,7 @@ } ); - binaryTarball = - nix: pkgs: pkgs.callPackage ./nix-support/binary-tarball.nix { inherit nix version; }; + binaryTarball = nix: pkgs: pkgs.callPackage ./nix-support/binary-tarball.nix { inherit nix; }; overlayFor = getStdenv: final: prev: @@ -330,10 +328,10 @@ pkgs = nixpkgsFor.${system}.native; image = import ./docker.nix { inherit pkgs; - tag = version; + tag = pkgs.nix.version; }; in - pkgs.runCommand "docker-image-tarball-${version}" + pkgs.runCommand "docker-image-tarball-${pkgs.nix.version}" { meta.description = "Docker image with Lix for ${system}"; } '' mkdir -p $out/nix-support |