aboutsummaryrefslogtreecommitdiff
path: root/flake.nix
diff options
context:
space:
mode:
authorQyriad <qyriad@qyriad.me>2024-04-17 20:07:38 -0600
committerQyriad <qyriad@qyriad.me>2024-04-22 21:41:58 -0600
commitb913a939b0aeccf979950f5dcb5089d565fee2a3 (patch)
treeb54bd7ba9c0597a96e267a41837ea684fc3f0674 /flake.nix
parent05e3b1d39eee5632d143ccd5a382b9d1ffe79fa6 (diff)
meson: flip the switch!!
This commit makes Meson the default buildsystem for Lix. The Make buildsystem is now deprecated and will be removed soon, but has not yet, which will be done in a later commit when all seems good. The mesonBuild jobs have been removed, and have not been replaced with equivalent jobs to ensure the Make buildsystem still works. The full, new commands in a development shell are: $ meson setup ./build "--prefix=$out" $mesonFlags (A simple `meson setup ./build` will also build, but will do a different thing, not having the settings from package.nix applied.) $ meson compile -C build $ meson test -C build --suite=check $ meson install -C build $ meson test -C build --suite=installcheck (Check and installcheck may both be done after install, allowing you to omit the --suite argument entirely, but this is the order package.nix runs them in.) If tests fail and Meson helpfully has no output for why, use the `--print-error-logs` option to `meson test`. Why this is not the default I cannot explain. If you change a setting in the buildsystem, most cases will automatically regenerate the Meson configuration, but some cases, like trying to build a specific target whose name is new to the buildsystem (e.g. `meson compile -C build src/libmelt/libmelt.dylib`, when `libmelt.dylib` did not exist as a target the last time the buildsystem was generated), then you can reconfigure using new settings but existing options, and only recompiling stuff affected by the changes: $ meson setup --reconfigure build Note that changes to the default values in `meson.options` or in the `default_options :` argument to project() are NOT propagated with `--reconfigure`. If you want a totally clean build, you can use: $ meson setup --wipe build That will work regardless of if `./build` exists or not. Specific, named targets may be addressed in `meson build -C build <target>` with the "target ID" if there is one, which is the first string argument passed to target functions that have one, and unrelated to the variable name, e.g.: libexpr_dylib = library('nixexpr', …) can be addressed with: $ meson compile -C build nixexpr All targets may be addressed as their output, relative to the build directory, e.g.: $ meson compile -C build src/libexpr/libnixexpr.so But Meson does not consider intermediate files like object files targets. To build a specific object file, use Ninja directly and specify the output file relative to the build directory: $ ninja -C build src/libexpr/libnixexpr.so.p/nixexpr.cc.o To inspect the canonical source of truth on what the state of the buildsystem configuration is, use: $ meson introspect Have fun! Change-Id: Ia3e7b1e6fae26daf3162e655b4ded611a5cd57ad
Diffstat (limited to 'flake.nix')
-rw-r--r--flake.nix22
1 files changed, 0 insertions, 22 deletions
diff --git a/flake.nix b/flake.nix
index bb03b16ab..e8526f5c4 100644
--- a/flake.nix
+++ b/flake.nix
@@ -196,24 +196,6 @@
}
);
- # FIXME(Qyriad): remove this when the migration to Meson has been completed.
- # NOTE: mesonBuildClang depends on mesonBuild depends on build to avoid OOMs
- # on aarch64 builders caused by too many parallel compiler/linker processes.
- mesonBuild = forAllSystems (
- system:
- (self.packages.${system}.nix.override { buildWithMeson = true; }).overrideAttrs (prev: {
- buildInputs = prev.buildInputs ++ [ self.packages.${system}.nix ];
- })
- );
- mesonBuildClang = forAllSystems (
- system:
- (nixpkgsFor.${system}.stdenvs.clangStdenvPackages.nix.override { buildWithMeson = true; })
- .overrideAttrs
- (prev: {
- buildInputs = prev.buildInputs ++ [ self.hydraJobs.mesonBuild.${system} ];
- })
- );
-
# Perl bindings for various platforms.
perlBindings = forAllSystems (system: nixpkgsFor.${system}.native.nix.perl-bindings);
@@ -237,7 +219,6 @@
inherit (pkgs) build-release-notes;
internalApiDocs = true;
busybox-sandbox-shell = pkgs.busybox-sandbox-shell;
- buildWithMeson = true;
};
in
nix.overrideAttrs (prev: {
@@ -367,9 +348,6 @@
checks = forAllSystems (
system:
{
- # FIXME(Qyriad): remove this when the migration to Meson has been completed.
- mesonBuild = self.hydraJobs.mesonBuild.${system};
- mesonBuildClang = self.hydraJobs.mesonBuildClang.${system};
binaryTarball = self.hydraJobs.binaryTarball.${system};
perlBindings = self.hydraJobs.perlBindings.${system};
nixpkgsLibTests = self.hydraJobs.tests.nixpkgsLibTests.${system};