aboutsummaryrefslogtreecommitdiff
path: root/flake.nix
diff options
context:
space:
mode:
authorQyriad <qyriad@qyriad.me>2024-04-23 11:12:09 +0000
committerGerrit Code Review <gerrit@lix>2024-04-23 11:12:09 +0000
commitbe4a3168c9bba52c7bb35e107a1ed917be41aa86 (patch)
tree96db7646c7e893727c622d6c8ed21535d398cae7 /flake.nix
parent86bfede948db03181cdf2989ee33b96905366f1b (diff)
parentb913a939b0aeccf979950f5dcb5089d565fee2a3 (diff)
Merge changes Ia3e7b1e6,If09be814 into main
* changes: meson: flip the switch!! meson: fix cross compilation
Diffstat (limited to 'flake.nix')
-rw-r--r--flake.nix22
1 files changed, 0 insertions, 22 deletions
diff --git a/flake.nix b/flake.nix
index bb03b16ab..e8526f5c4 100644
--- a/flake.nix
+++ b/flake.nix
@@ -196,24 +196,6 @@
}
);
- # FIXME(Qyriad): remove this when the migration to Meson has been completed.
- # NOTE: mesonBuildClang depends on mesonBuild depends on build to avoid OOMs
- # on aarch64 builders caused by too many parallel compiler/linker processes.
- mesonBuild = forAllSystems (
- system:
- (self.packages.${system}.nix.override { buildWithMeson = true; }).overrideAttrs (prev: {
- buildInputs = prev.buildInputs ++ [ self.packages.${system}.nix ];
- })
- );
- mesonBuildClang = forAllSystems (
- system:
- (nixpkgsFor.${system}.stdenvs.clangStdenvPackages.nix.override { buildWithMeson = true; })
- .overrideAttrs
- (prev: {
- buildInputs = prev.buildInputs ++ [ self.hydraJobs.mesonBuild.${system} ];
- })
- );
-
# Perl bindings for various platforms.
perlBindings = forAllSystems (system: nixpkgsFor.${system}.native.nix.perl-bindings);
@@ -237,7 +219,6 @@
inherit (pkgs) build-release-notes;
internalApiDocs = true;
busybox-sandbox-shell = pkgs.busybox-sandbox-shell;
- buildWithMeson = true;
};
in
nix.overrideAttrs (prev: {
@@ -367,9 +348,6 @@
checks = forAllSystems (
system:
{
- # FIXME(Qyriad): remove this when the migration to Meson has been completed.
- mesonBuild = self.hydraJobs.mesonBuild.${system};
- mesonBuildClang = self.hydraJobs.mesonBuildClang.${system};
binaryTarball = self.hydraJobs.binaryTarball.${system};
perlBindings = self.hydraJobs.perlBindings.${system};
nixpkgsLibTests = self.hydraJobs.tests.nixpkgsLibTests.${system};