aboutsummaryrefslogtreecommitdiff
path: root/flake.nix
diff options
context:
space:
mode:
authorsternenseemann <0rpkxez4ksa01gb3typccl0i@systemli.org>2021-02-06 12:59:11 +0100
committersternenseemann <0rpkxez4ksa01gb3typccl0i@systemli.org>2021-02-06 13:14:57 +0100
commitd0e34c85f85510cb2ef591de29693b4cf8bdc65b (patch)
tree0be80ef1bd8cbe762eaaf59468b97396b63ac60c /flake.nix
parent480426a364f09e7992230b32f2941a09fb52d729 (diff)
libcmd/markdown: handle allocation errors in lowdown_term_rndr
We upgrade to lowdown 0.8.0 [1] which contains a fix/improvement to a behavior mentioned in this issue thread [2] where a big part of lowdown's API would just call exit(1) on allocation errors since that is a satisfying behavior for the lowdown binary. Now lowdown_term_rndr returns 0 if an allocation error occurred which we check for in libcmd/markdown.cc. Also the extern "C" { } wrapper around lowdown.h has been removed as it is not necessary. [1]: https://github.com/kristapsdz/lowdown/blob/6ca7c855a063d1c77ae0b89405047cc3913a74d8/versions.xml#L987-L1006 [2]: https://github.com/kristapsdz/lowdown/issues/45#issuecomment-756681153
Diffstat (limited to 'flake.nix')
-rw-r--r--flake.nix8
1 files changed, 4 insertions, 4 deletions
diff --git a/flake.nix b/flake.nix
index d94da9dae..8c60934e6 100644
--- a/flake.nix
+++ b/flake.nix
@@ -198,12 +198,12 @@
};
- lowdown = with final; stdenv.mkDerivation {
- name = "lowdown-0.7.9";
+ lowdown = with final; stdenv.mkDerivation rec {
+ name = "lowdown-0.8.0";
src = fetchurl {
- url = https://kristaps.bsd.lv/lowdown/snapshots/lowdown-0.7.9.tar.gz;
- hash = "sha512-7GQrKFICyTI5T4SinATfohiCq9TC0OgN8NmVfG3B3BZJM9J00DT8llAco8kNykLIKtl/AXuS4X8fETiCFEWEUQ==";
+ url = "https://kristaps.bsd.lv/lowdown/snapshots/${name}.tar.gz";
+ hash = "sha512-U9WeGoInT9vrawwa57t6u9dEdRge4/P+0wLxmQyOL9nhzOEUU2FRz2Be9H0dCjYE7p2v3vCXIYk40M+jjULATw==";
};
#src = lowdown-src;