diff options
author | Jade Lovelace <lix@jade.fyi> | 2024-07-23 22:43:38 +0200 |
---|---|---|
committer | Jade Lovelace <lix@jade.fyi> | 2024-07-31 14:13:39 -0700 |
commit | e51263057f21e77602481d6a6d826ff8cc0c1db0 (patch) | |
tree | 821ee4284b14626fa39bc485cffb709014661b47 /flake.nix | |
parent | 19ae87e5cec71912c7e7ecec5dc8ff18d18c60ee (diff) |
ci: add a asan+ubsan test run on x86_64-linux
This should at least catch out blatantly bad patches that don't pass the
test suite with ASan. We don't do this to the integration tests since
they run on relatively limited-memory VMs and so it may not be super
safe to run an evaluator with leak driven garbage collection for them.
Fixes: https://git.lix.systems/lix-project/lix/issues/403
Fixes: https://git.lix.systems/lix-project/lix/issues/319
Change-Id: I5267b02626866fd33e8b4d8794344531af679f78
Diffstat (limited to 'flake.nix')
-rw-r--r-- | flake.nix | 9 |
1 files changed, 9 insertions, 0 deletions
@@ -275,6 +275,15 @@ # System tests. tests = import ./tests/nixos { inherit lib nixpkgs nixpkgsFor; } // { + # This is x86_64-linux only, just because we have significantly + # cheaper x86_64-linux compute in CI. + # It is clangStdenv because clang's sanitizers are nicer. + asanBuild = self.packages.x86_64-linux.nix-clangStdenv.override { + sanitize = [ + "address" + "undefined" + ]; + }; # Make sure that nix-env still produces the exact same result # on a particular version of Nixpkgs. |