diff options
author | eldritch horrors <pennae@lix.systems> | 2024-07-09 22:50:51 +0200 |
---|---|---|
committer | eldritch horrors <pennae@lix.systems> | 2024-07-09 22:50:51 +0200 |
commit | f5aa5b6815e6cd9194c7dec03651066e4cab5783 (patch) | |
tree | 1185f99aba182611b28c00623df04aa503f1afc7 /flake.nix | |
parent | 4d8c66ec6fee1f476c495297c48e3167fd6378ed (diff) |
releng: add releaseTests flake output, test script
this is supposed to be a set of outputs we want to always succeed for
releases. sadly we can't add nixos installer tests using lix to these
because the nixos test framework does not allow overriding nix in the
installer test suites due to unfortunate oversights in the framework.
Change-Id: I815520181ccca70a47205d38ba27e73529347f04
Diffstat (limited to 'flake.nix')
-rw-r--r-- | flake.nix | 19 |
1 files changed, 19 insertions, 0 deletions
@@ -329,6 +329,25 @@ pkgs = nixpkgsFor.x86_64-linux.native; }; + releaseTests = lib.foldl lib.recursiveUpdate { } [ + (lib.genAttrs (linux64BitSystems ++ darwinSystems) (system: { + nativeBuild = self.packages.${system}.nix; + })) + (lib.genAttrs (linux64BitSystems) (system: { + staticBuild = self.packages.${system}.nix-static; + })) + { + x86_64-linux = { + # TODO add more cross/static release targets? + crossBuild.aarch64-linux = self.packages.x86_64-linux.nix-aarch64-linux; + + # TODO wire up a nixos installer test with that lix and + # run it, once nixpkgs can actually do that (again). :/ + # # nix build .#nixosTests.installer.{btrfsSimple,luksroot,lvm,simple,switchToFlake} + }; + } + ]; + # NOTE *do not* add fresh derivations to checks, always add them to # hydraJobs first (so CI will pick them up) and only link them here checks = forAvailableSystems ( |