aboutsummaryrefslogtreecommitdiff
path: root/maintainers/build-release-notes.nix
diff options
context:
space:
mode:
authoreldritch horrors <pennae@lix.systems>2024-03-26 18:32:25 +0100
committereldritch horrors <pennae@lix.systems>2024-03-27 03:09:14 +0000
commit279e30e7ef4cae96d1f5fcbc5fc02ebb4779199b (patch)
tree045935b89a5067c297cb50e7a28ca3a81cf411fc /maintainers/build-release-notes.nix
parent8fd02df90d2a8099d2d547e151b876f77fb5a4a2 (diff)
build: replace changelog-d with local script
hacking changelog-d to support not just github but also forgejo and gerrit is a lot more complicated than it's worth, even moreso since the entire thing can just as well be done with ~60 lines of python. this new script is also much cheaper to instantiate (being python), so having it enabled in all shells is far less of a hassle. we've also adjusted existing release notes that referenced a gerrit cl to auto-link to the cl in question, making the diff a bit bigger closes https://git.lix.systems/lix-project/lix/issues/176 Change-Id: I8ba7dd0070aad9ba4474401731215fcf5d9d2130
Diffstat (limited to 'maintainers/build-release-notes.nix')
-rw-r--r--maintainers/build-release-notes.nix6
1 files changed, 6 insertions, 0 deletions
diff --git a/maintainers/build-release-notes.nix b/maintainers/build-release-notes.nix
new file mode 100644
index 000000000..9462e33d7
--- /dev/null
+++ b/maintainers/build-release-notes.nix
@@ -0,0 +1,6 @@
+{ lib, python3, writeShellScriptBin }:
+
+writeShellScriptBin "build-release-notes" ''
+ exec ${lib.getExe (python3.withPackages (p: [ p.python-frontmatter ]))} \
+ ${./build-release-notes.py} "$@"
+''