aboutsummaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authoreldritch horrors <pennae@lix.systems>2024-06-30 20:51:10 +0200
committereldritch horrors <pennae@lix.systems>2024-06-30 21:30:43 +0000
commit010ff57ebb40f1a9aaff99867d2886f0e59f774a (patch)
treed36322405e9221d287a757715708568009e87948 /meson.build
parenta55112898e23df10a7a0d2a0cd359996100e3512 (diff)
enable -Werror=unused-result
we do not have any of these warnings appearing at the moment, but it seems like a good idea to enable [[nodiscard]] checking anyway. once we start introducing more functions with must-use conditions we will need such checking, and the rust stdlib has proven them very useful. Change-Id: Ibb6b042ae1ec5f527f8dc2809a7816a4c1548ae2
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build1
1 files changed, 1 insertions, 0 deletions
diff --git a/meson.build b/meson.build
index 0cb2030e7..7d8a3a315 100644
--- a/meson.build
+++ b/meson.build
@@ -432,6 +432,7 @@ add_project_arguments(
'-Wimplicit-fallthrough',
'-Werror=switch',
'-Werror=switch-enum',
+ '-Werror=unused-result',
'-Wdeprecated-copy',
'-Wignored-qualifiers',
# Enable assertions in libstdc++ by default. Harmless on libc++. Benchmarked