aboutsummaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorJade Lovelace <lix@jade.fyi>2024-04-07 16:16:21 -0700
committerjade <lix@jade.fyi>2024-04-08 04:05:13 +0000
commit0145d45806b1f60e9c7221a1f063a1b336a98eb4 (patch)
treecfe9ec77f0323da70fb297667c7df14ab137fcf5 /meson.build
parentb995c17f0eb8d9598f339c080c467101c1f55feb (diff)
nix-doc -> lix-doc, make self-contained in package.nix
package.nix previously needed this callPackage'd externally, which didn't make a lot of sense to us since this is an internal dependency. Thus we changed it to make it more self contained. Change-Id: I4935bc0bc80e1a132bc9b1519e917791da95037c
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build9
1 files changed, 6 insertions, 3 deletions
diff --git a/meson.build b/meson.build
index 89881e190..2cedabad5 100644
--- a/meson.build
+++ b/meson.build
@@ -233,10 +233,13 @@ deps += toml11
nlohmann_json = dependency('nlohmann_json', required : true)
deps += nlohmann_json
-# nix-doc is a Rust project provided via buildInputs and unfortunately doesn't have any way to be detected.
+# lix-doc is a Rust project provided via buildInputs and unfortunately doesn't have any way to be detected.
# Just declare it manually to resolve this.
-nix_doc = declare_dependency(link_args : [ '-lnix_doc' ])
-deps += nix_doc
+#
+# FIXME: build this with meson in the future after we drop Make (with which we
+# *absolutely* are not going to make it work)
+lix_doc = declare_dependency(link_args : [ '-llix_doc' ])
+deps += lix_doc
#
# Build-time tools