aboutsummaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorArtemis Tosini <me@artem.ist>2024-07-20 03:18:39 +0000
committerArtemis Tosini <me@artem.ist>2024-07-23 17:49:33 +0000
commit53f3e39815c3357c6465963359e94a6318b54af7 (patch)
tree3a251fe37ec302e404f50a0fd6bbe6daa0b90646 /meson.build
parent73c013a5df09a9edf7a6d2fa0be8349d89f856cd (diff)
libstore: Add FreeBSD findPlatformRoots
Use libprocstat to find garbage collector roots on FreeBSD. Tested working on a FreeBSD machine, although there is no CI yet Change-Id: Id36bac8c3de6cc4de94e2d76e9663dd4b76068a9
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build4
1 files changed, 4 insertions, 0 deletions
diff --git a/meson.build b/meson.build
index 0e74520ca..56f447501 100644
--- a/meson.build
+++ b/meson.build
@@ -314,6 +314,10 @@ nlohmann_json = dependency('nlohmann_json', required : true)
# *absolutely* are not going to make it work)
lix_doc = declare_dependency(link_args : [ '-llix_doc' ])
+if is_freebsd
+ libprocstat = declare_dependency(link_args : [ '-lprocstat' ])
+endif
+
#
# Build-time tools
#