aboutsummaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorWinter <winter@winter.cafe>2024-03-26 23:09:43 -0400
committerWinter <winter@winter.cafe>2024-03-29 14:16:58 -0400
commit6646b803964cc60a25723ac92cf97d4e828a83c3 (patch)
tree4ede17db75a636f530fc1d7a03b5b7d83b781a2c /meson.build
parent9d97d1cb68e6a374f07294c4d46ac8ed1485ce23 (diff)
meson: add missing explicit dependency on nlohmann_json
Without this, the Meson setup won't bail out if nlohmann_json is missing, leading to subpar DX (and maybe worse, but I'm not entirely sure). Change-Id: I5913111060226b540dcf003257c99a08e84da0de
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build3
1 files changed, 3 insertions, 0 deletions
diff --git a/meson.build b/meson.build
index a4c2bbc14..ca250ce99 100644
--- a/meson.build
+++ b/meson.build
@@ -214,6 +214,9 @@ deps += gtest
toml11 = dependency('toml11', version : '>=3.7.0', required : true)
deps += toml11
+nlohmann_json = dependency('nlohmann_json', required : true)
+deps += nlohmann_json
+
#
# Build-time tools
#