aboutsummaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorLunaphied <lunaphied@lunaphied.me>2024-03-17 18:01:05 -0600
committerLunaphied <lunaphied@lunaphied.me>2024-04-03 13:47:22 -0600
commit7a1054fa5f223126833718fc3f332579dba5f0f7 (patch)
tree790daae10628ec42436d79c943dcbcd8d7168fd6 /meson.build
parent56c7dfd65290dea957de6fad4e2df26f1630e407 (diff)
repl: improve `:doc` builtin repl command to support lambdas.
For a long time `nix repl` has supported displaying documentation set on builtins, however, it has long been convention to use Markdown comments on Nix functions themselves for documentation. This exposes that information to `nix repl` users in a nice and formatted way. NixOS/rfcs#145 doc-comments are primarily what this feature is intended to consume, however, support for lambda documentation in the repl is experimental. We do our best effort to support the RFC here. These changes are based on [the nix-doc library](https://github.com/lf-/nix-doc) and are licensed under the terms described in the relevant source files. Change-Id: Ic6fe947d39a22540705d890737e336c4720b0a22
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build5
1 files changed, 5 insertions, 0 deletions
diff --git a/meson.build b/meson.build
index dadb01b9c..66c664282 100644
--- a/meson.build
+++ b/meson.build
@@ -219,6 +219,11 @@ deps += toml11
nlohmann_json = dependency('nlohmann_json', required : true)
deps += nlohmann_json
+# nix-doc is a Rust project provided via buildInputs and unfortunately doesn't have any way to be detected.
+# Just declare it manually to resolve this.
+nix_doc = declare_dependency(link_args : [ '-lnix_doc' ])
+deps += nix_doc
+
#
# Build-time tools
#