aboutsummaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorJade Lovelace <lix@jade.fyi>2024-06-06 11:35:03 -0700
committerJade Lovelace <lix@jade.fyi>2024-06-06 15:08:12 -0700
commit9c77c62e731e3fb9b1a87414c5b2d7a52932a507 (patch)
tree3e2ec9a7ff5156be6828006a4890b641b4729bd9 /meson.build
parent24057dcb6a5d33806de66de1e42137eca398350e (diff)
Move version to a JSON file so we can have release names
Change-Id: I5ff3396a302565ee5ee6c2db97e048e403779076
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build2
1 files changed, 1 insertions, 1 deletions
diff --git a/meson.build b/meson.build
index b98b1fb15..51c7bda59 100644
--- a/meson.build
+++ b/meson.build
@@ -39,7 +39,7 @@
# in the build directory.
project('lix', 'cpp',
- version : run_command('bash', '-c', 'echo -n $(cat ./.version)$VERSION_SUFFIX', check : true).stdout().strip(),
+ version : run_command('bash', '-c', 'echo -n $(jq -r .version < ./version.json)$VERSION_SUFFIX', check : true).stdout().strip(),
default_options : [
'cpp_std=c++2a',
# TODO(Qyriad): increase the warning level