aboutsummaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authoreldritch horrors <pennae@lix.systems>2024-07-22 17:15:57 +0200
committereldritch horrors <pennae@lix.systems>2024-07-22 16:26:55 +0000
commitc74eb81356ef0e202713111d621434e46edc27ea (patch)
treea292f39326e0da00685d8d7071789dcd82261187 /meson.build
parent0463cf2aefafcbf3762ffdfa6df3f1eb8fa21bfd (diff)
enable -Werror=suggest-override
*accidentally* overriding a function is almost guaranteed to be an error. overriding a function without labeling it as such is merely bad style, but bad style that makes the code harder to understand. Change-Id: Ic0594f3d1604ab6b3c1a75cb5facc246effe45f0
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build1
1 files changed, 1 insertions, 0 deletions
diff --git a/meson.build b/meson.build
index 8ce06800b..0e74520ca 100644
--- a/meson.build
+++ b/meson.build
@@ -445,6 +445,7 @@ add_project_arguments(
'-Werror=unused-result',
'-Wdeprecated-copy',
'-Wignored-qualifiers',
+ '-Werror=suggest-override',
# Enable assertions in libstdc++ by default. Harmless on libc++. Benchmarked
# at ~1% overhead in `nix search`.
#