aboutsummaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authoreldritch horrors <pennae@lix.systems>2024-03-30 16:28:59 +0100
committereldritch horrors <pennae@lix.systems>2024-04-01 20:15:28 +0000
commited2bb919e79715918a88646c15a6642e7dcd3a98 (patch)
treea1da2b63fc8e99b653210fdc404282260b7841fd /meson.build
parentefbf5c81bb9c58487fd08f236251627fbb27f780 (diff)
meson: add switch to disable docs
the make build system can do this too. Change-Id: I8c07d159cab54a8749c50dc33615f60bd251a86d
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build6
1 files changed, 5 insertions, 1 deletions
diff --git a/meson.build b/meson.build
index 5bb7d3738..dadb01b9c 100644
--- a/meson.build
+++ b/meson.build
@@ -71,6 +71,7 @@ foreach optname : path_opts
endif
endforeach
+enable_docs = get_option('enable-docs')
enable_tests = get_option('enable-tests')
@@ -357,7 +358,10 @@ endif
subdir('src')
subdir('scripts')
subdir('misc')
-subdir('doc/manual')
+
+if enable_docs
+ subdir('doc/manual')
+endif
if enable_tests
subdir('tests/unit')