aboutsummaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorLulu <lulu.berlin.2023@gmail.com>2024-10-06 22:10:40 +0200
committerLulu <lulu.berlin.2023@gmail.com>2024-10-08 01:44:38 +0000
commit43e79f443469c55ef4d3a43ce1e455d6eafcd26c (patch)
tree86e67212f01f1cf18c05b75b4321ffac6b620a1e /meson.build
parent299813f324c9562b0bd6d0bc5d2114776e193d86 (diff)
Fix gcc warning -Wmissing-field-initializers
The approach that was taken here was to add default values to the type definitions rather than specify them whenever they are missing. Now the only remaining warning is '-Wunused-parameter' which @jade said is usually counterproductive and that we can just disable it: https://git.lix.systems/lix-project/lix/issues/456#issuecomment-6617 So this change adds the flags '-Wall', '-Wextra' and '-Wno-unused-parameter', so that all warnings are enabled except for '-Wunused-parameter'. Change-Id: Ic223a964d67ab429e8da804c0721ba5e25d53012
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build5
1 files changed, 2 insertions, 3 deletions
diff --git a/meson.build b/meson.build
index fca9f4ed3..c7fe647ce 100644
--- a/meson.build
+++ b/meson.build
@@ -52,8 +52,7 @@ project('lix', 'cpp', 'rust',
default_options : [
'cpp_std=c++2a',
'rust_std=2021',
- # TODO(Qyriad): increase the warning level
- 'warning_level=1',
+ 'warning_level=2',
'debug=true',
'optimization=2',
'errorlogs=true', # Please print logs for tests that fail
@@ -485,7 +484,7 @@ add_project_arguments(
# TODO(Qyriad): Yes this is how the autoconf+Make system did it.
# It would be nice for our headers to be idempotent instead.
'-include', 'config.h',
- '-Wsign-compare',
+ '-Wno-unused-parameter',
'-Wno-deprecated-declarations',
'-Wimplicit-fallthrough',
'-Werror=switch',