aboutsummaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorLulu <lulu.berlin.2023@gmail.com>2024-10-06 20:47:32 +0200
committerLulu <lulu.berlin.2023@gmail.com>2024-10-08 01:32:12 +0200
commitd6e1b11d3e91abc4194744310f36e37a57dd6e1d (patch)
treec2877e39ef28788c5a9596915ca40601c40ea14e /meson.build
parented9b7f4f84fd60ad8618645cc1bae2d686ff0db6 (diff)
Fix gcc warning -Wsign-compare
Add the compile flag '-Wsign-compare' and adapt the code to fix all cases of this warning. Change-Id: I26b08fa5a03e4ac294daf697d32cf9140d84350d
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build1
1 files changed, 1 insertions, 0 deletions
diff --git a/meson.build b/meson.build
index a8c6b9621..fca9f4ed3 100644
--- a/meson.build
+++ b/meson.build
@@ -485,6 +485,7 @@ add_project_arguments(
# TODO(Qyriad): Yes this is how the autoconf+Make system did it.
# It would be nice for our headers to be idempotent instead.
'-include', 'config.h',
+ '-Wsign-compare',
'-Wno-deprecated-declarations',
'-Wimplicit-fallthrough',
'-Werror=switch',