aboutsummaryrefslogtreecommitdiff
path: root/misc/changelog-d.cabal.nix
diff options
context:
space:
mode:
authoreldritch horrors <pennae@lix.systems>2024-03-04 07:12:09 +0100
committereldritch horrors <pennae@lix.systems>2024-03-04 07:12:09 +0100
commit116e48fad3bf91ffd179c048cd0444de5a65719f (patch)
treeffcfee95aa6e96927566cadd5a0c7ca9d9aec8fe /misc/changelog-d.cabal.nix
parent2ba978800355189e263aa7fe13277fd62ce743bc (diff)
Merge pull request #9573 from hercules-ci/rl-next-md-frontmatter
rl-next: Fix and support markdown frontmatter syntax (cherry picked from commit 69b7876a0810269ad71807594cfd99b26cd8a5ff) Change-Id: I8bfb8967af0943080fdd70d257c34abaf0a9fedf
Diffstat (limited to 'misc/changelog-d.cabal.nix')
-rw-r--r--misc/changelog-d.cabal.nix31
1 files changed, 31 insertions, 0 deletions
diff --git a/misc/changelog-d.cabal.nix b/misc/changelog-d.cabal.nix
new file mode 100644
index 000000000..76f9353cd
--- /dev/null
+++ b/misc/changelog-d.cabal.nix
@@ -0,0 +1,31 @@
+{ mkDerivation, aeson, base, bytestring, cabal-install-parsers
+, Cabal-syntax, containers, directory, filepath, frontmatter
+, generic-lens-lite, lib, mtl, optparse-applicative, parsec, pretty
+, regex-applicative, text, pkgs
+}:
+let rev = "f30f6969e9cd8b56242309639d58acea21c99d06";
+in
+mkDerivation {
+ pname = "changelog-d";
+ version = "0.1";
+ src = pkgs.fetchurl {
+ name = "changelog-d-${rev}.tar.gz";
+ url = "https://codeberg.org/roberth/changelog-d/archive/${rev}.tar.gz";
+ hash = "sha256-8a2+i5u7YoszAgd5OIEW0eYUcP8yfhtoOIhLJkylYJ4=";
+ } // { inherit rev; };
+ isLibrary = false;
+ isExecutable = true;
+ libraryHaskellDepends = [
+ aeson base bytestring cabal-install-parsers Cabal-syntax containers
+ directory filepath frontmatter generic-lens-lite mtl parsec pretty
+ regex-applicative text
+ ];
+ executableHaskellDepends = [
+ base bytestring Cabal-syntax directory filepath
+ optparse-applicative
+ ];
+ doHaddock = false;
+ description = "Concatenate changelog entries into a single one";
+ license = lib.licenses.gpl3Plus;
+ mainProgram = "changelog-d";
+}