aboutsummaryrefslogtreecommitdiff
path: root/misc/changelog-d.nix
diff options
context:
space:
mode:
authoreldritch horrors <pennae@lix.systems>2024-03-26 18:32:25 +0100
committereldritch horrors <pennae@lix.systems>2024-03-27 03:09:14 +0000
commit279e30e7ef4cae96d1f5fcbc5fc02ebb4779199b (patch)
tree045935b89a5067c297cb50e7a28ca3a81cf411fc /misc/changelog-d.nix
parent8fd02df90d2a8099d2d547e151b876f77fb5a4a2 (diff)
build: replace changelog-d with local script
hacking changelog-d to support not just github but also forgejo and gerrit is a lot more complicated than it's worth, even moreso since the entire thing can just as well be done with ~60 lines of python. this new script is also much cheaper to instantiate (being python), so having it enabled in all shells is far less of a hassle. we've also adjusted existing release notes that referenced a gerrit cl to auto-link to the cl in question, making the diff a bit bigger closes https://git.lix.systems/lix-project/lix/issues/176 Change-Id: I8ba7dd0070aad9ba4474401731215fcf5d9d2130
Diffstat (limited to 'misc/changelog-d.nix')
-rw-r--r--misc/changelog-d.nix31
1 files changed, 0 insertions, 31 deletions
diff --git a/misc/changelog-d.nix b/misc/changelog-d.nix
deleted file mode 100644
index 1b20f4596..000000000
--- a/misc/changelog-d.nix
+++ /dev/null
@@ -1,31 +0,0 @@
-# Taken temporarily from <nixpkgs/pkgs/by-name/ch/changelog-d/package.nix>
-{
- callPackage,
- lib,
- haskell,
- haskellPackages,
-}:
-
-let
- hsPkg = haskellPackages.callPackage ./changelog-d.cabal.nix { };
-
- addCompletions = haskellPackages.generateOptparseApplicativeCompletions ["changelog-d"];
-
- haskellModifications =
- lib.flip lib.pipe [
- addCompletions
- haskell.lib.justStaticExecutables
- ];
-
- mkDerivationOverrides = finalAttrs: oldAttrs: {
-
- version = oldAttrs.version + "-git-${lib.strings.substring 0 7 oldAttrs.src.rev}";
-
- meta = oldAttrs.meta // {
- homepage = "https://codeberg.org/roberth/changelog-d";
- maintainers = [ lib.maintainers.roberth ];
- };
-
- };
-in
- (haskellModifications hsPkg).overrideAttrs mkDerivationOverrides