aboutsummaryrefslogtreecommitdiff
path: root/nix-rust/Cargo.toml
diff options
context:
space:
mode:
authorEelco Dolstra <edolstra@gmail.com>2019-11-29 18:27:40 +0100
committerEelco Dolstra <edolstra@gmail.com>2019-11-29 18:30:39 +0100
commit39954a958623431acb8642372f881cbdb7bb789d (patch)
treef1269181a1d02cfaa202abaa8ddb0417afe7eec7 /nix-rust/Cargo.toml
parent895ce1bb6cc77324c377baa08eb98666768e5c6d (diff)
Make libnixrust a dynamic library
This is a hack to fix the build on macOS, which was failing because libnixrust.a contains compiler builtins that clash with libclang_rt.osx.a. There's probably a better solution... https://hydra.nixos.org/build/107473280
Diffstat (limited to 'nix-rust/Cargo.toml')
-rw-r--r--nix-rust/Cargo.toml2
1 files changed, 1 insertions, 1 deletions
diff --git a/nix-rust/Cargo.toml b/nix-rust/Cargo.toml
index 8b56dc89c..c4f4ceb09 100644
--- a/nix-rust/Cargo.toml
+++ b/nix-rust/Cargo.toml
@@ -6,7 +6,7 @@ edition = "2018"
[lib]
name = "nixrust"
-crate-type = ["staticlib"]
+crate-type = ["cdylib"]
[dependencies]
tar = "0.4"