aboutsummaryrefslogtreecommitdiff
path: root/package.nix
diff options
context:
space:
mode:
authorJade Lovelace <lix@jade.fyi>2024-04-07 16:16:21 -0700
committerjade <lix@jade.fyi>2024-04-08 04:05:13 +0000
commit0145d45806b1f60e9c7221a1f063a1b336a98eb4 (patch)
treecfe9ec77f0323da70fb297667c7df14ab137fcf5 /package.nix
parentb995c17f0eb8d9598f339c080c467101c1f55feb (diff)
nix-doc -> lix-doc, make self-contained in package.nix
package.nix previously needed this callPackage'd externally, which didn't make a lot of sense to us since this is an internal dependency. Thus we changed it to make it more self contained. Change-Id: I4935bc0bc80e1a132bc9b1519e917791da95037c
Diffstat (limited to 'package.nix')
-rw-r--r--package.nix7
1 files changed, 5 insertions, 2 deletions
diff --git a/package.nix b/package.nix
index b972407f1..d096b5c73 100644
--- a/package.nix
+++ b/package.nix
@@ -48,7 +48,8 @@
busybox-sandbox-shell,
- nix-doc,
+ # internal fork of nix-doc providing :doc in the repl
+ lix-doc ? __forDefaults.lix-doc,
pname ? "nix",
versionSuffix ? "",
@@ -81,6 +82,8 @@
./boehmgc-traceable_allocator-public.diff
];
};
+
+ lix-doc = pkgs.callPackage ./lix-doc/package.nix { };
},
}: let
inherit (__forDefaults) canRunInstalled;
@@ -209,7 +212,7 @@ in stdenv.mkDerivation (finalAttrs: {
lowdown
libsodium
toml11
- nix-doc
+ lix-doc
]
++ lib.optionals stdenv.hostPlatform.isLinux [ libseccomp busybox-sandbox-shell ]
++ lib.optional stdenv.hostPlatform.isx86_64 libcpuid