aboutsummaryrefslogtreecommitdiff
path: root/package.nix
diff options
context:
space:
mode:
authorQyriad <qyriad@qyriad.me>2024-04-18 16:15:24 -0600
committerQyriad <qyriad@qyriad.me>2024-04-18 16:15:58 -0600
commit111db8b38fd8350d92d72fa17fd3d9e8ef5a0e09 (patch)
tree93d0687870293ef4c59bc327c2bd2057c7ceebc5 /package.nix
parenta326344253ee55d50476ff696b83ffb15366852d (diff)
meson: correctly embed sandbox shell when asked
Change-Id: I2f6c0d42245204a516d2e424eea26a6391e975ad
Diffstat (limited to 'package.nix')
-rw-r--r--package.nix1
1 files changed, 1 insertions, 0 deletions
diff --git a/package.nix b/package.nix
index aab98c0ae..9a2e08038 100644
--- a/package.nix
+++ b/package.nix
@@ -182,6 +182,7 @@ stdenv.mkDerivation (finalAttrs: {
lib.optionals (buildWithMeson && stdenv.hostPlatform.isLinux) [
"-Dsandbox-shell=${lib.getBin busybox-sandbox-shell}/bin/busybox"
]
+ ++ lib.optional stdenv.hostPlatform.isStatic "-Denable-embedded-sandbox-shell=true"
++ lib.optional (finalAttrs.dontBuild) "-Denable-build=false"
# mesonConfigurePhase automatically passes -Dauto_features=enabled,
# so we must explicitly enable or disable features that we are not passing