aboutsummaryrefslogtreecommitdiff
path: root/package.nix
diff options
context:
space:
mode:
authorJade Lovelace <lix@jade.fyi>2024-05-15 15:01:38 -0700
committerJade Lovelace <lix@jade.fyi>2024-05-15 15:01:38 -0700
commit7cfaf057e35b7bb329ffff344e30fdfc850566c3 (patch)
tree46de91ec8f17defa6e25d81263e30af77adec259 /package.nix
parent2a7b3d7c94e266ef1b48d10ccbb023b1bf646424 (diff)
release-notes: build unreleased release notes by default
Surely if you have unreleased changes you want them on a page right? `officialRelease` means "this is a *release version*", which is a reasonable case to not want it, but we are not that here. I understand wanting to be able to turn it off for deps reasons or something, but other than that, uhh, seems better to just turn it on always; it is basically free compute-wise to the point we run it on pre-commit. Part two of fixing lix#297. Fixes: https://git.lix.systems/lix-project/lix/issues/297 Change-Id: I0f8dd1ae42458df371aef529c456e47a7ac04ae0
Diffstat (limited to 'package.nix')
-rw-r--r--package.nix4
1 files changed, 2 insertions, 2 deletions
diff --git a/package.nix b/package.nix
index 0186b7472..83a4411ec 100644
--- a/package.nix
+++ b/package.nix
@@ -51,9 +51,9 @@
pname ? "nix",
versionSuffix ? "",
- officialRelease ? true,
+ officialRelease ? false,
# Set to true to build the release notes for the next release.
- buildUnreleasedNotes ? false,
+ buildUnreleasedNotes ? true,
internalApiDocs ? false,
# Not a real argument, just the only way to approximate let-binding some